Tuesday, May 22, 2018

News

Vigil Releases Service Bulletin for Mandatory Compliance

Vigil Releases Service Bulletin for Mandatory Compliance

Service Bulletins |

Advanced Aerospace Designs has released a Public Service Bulletin PSB-01-2018, regarding certain Vigil II and Vigil 2+ Automatic Activation Devices. The bulletin provides instructions for updating the firmware of affected units that can generate an error code during high-altitude jumps above 27,000 feet. Compliance is mandatory before any jump made from 27,000 feet, or higher, or by no later than May, 2020 for those with affected units who are not making any high altitude jumps.

Vigil AAD - PSB 01-2018 (PDF)

Print
Categories: Homepage, Skydiving News, Service Bulletins   |   Rate this article:
No rating
  |  Number of views: 388   |  Comments: 0
Tags:

Leave a comment

Name:
Email:
Comment:
Add comment

Name:
Email:
Subject:
Message:
x